Windows 10 (Build 14393.351): Explorer stürzt ab

Derzeit existiert ein Bug in Windows 10, welcher den Explorer beim Zugriff auf lange Pfade regelmäßig zum Absturz bringt. Besonders unangenehm daran ist, dass es bereits reicht, wenn sich eine entsprechende Datei in der Liste der zuletzt verwendeten Dateien befindet und dieser Eintrag z.B. durch Scrollen mit dem Mausrad oder Benutzen der Bildlaufleiste in den sichtbaren Bereich gebracht wird. Windows Explorer verabschiedet sich in solchen Fällen inclusive aller geöffneter Fenster und startet neu.

Im Anwendungsprotokoll finden sich in der Folge Einträge wie:
Application Error – EventID 1000
Name der fehlerhaften Anwendung: explorer.exe, Version: 10.0.14393.351, Zeitstempel: xxxxxxxx
Name des fehlerhaften Moduls: ntdll.dll, Version: 10.0.14393.351

Lösung 1: Warten. Microsoft ist gerade dabei, eine Möglichkeit zur Verarbeitung längerer Pfade als 260 Zeichen einzuführen.
(Details bei superuser.com)

Lösung 2: Aufräumen. Dateiablage so umgestalten, dass überlange Pfade nicht mehr vorkommen.

Lösung 3 (provisorisch): Explorer so konfigurieren, dass er keine Miniaturansichten anzeigt.
(Details bei answers.microsoft.com)

Ralph Lehmann :: Computerservice und IT-Beratung

Gleicher Name, gleiches Kennwort …

und der Zugriff klappt in einem Windows-Netzwerk … dachte ich jedenfalls bis jetzt. Heute wurde ich eines Besseren belehrt. 😉

Szenario eins: Anmeldung an Windows 10.0.10240 mit einem lokalen Konto. Zugriff auf Netzwerkfreigaben im Arbeitsgruppennetzwerk (mit Benutzer + Kennwort-Kombination, die auf der Freigabe als berechtigt hinterlegt ist):
Server 2012R1 … funktioniert
Windows 8.1 ….. funktioniert
Windows 10 …… funktioniert

Szenario zwei: Anmeldung an Windows 10.0.10240 mit einem Microsoft Konto. Zugriff auf Netzwerkfreigaben im Arbeitsgruppennetzwerk (mit Benutzer + Kennwort-Kombination, die auf der Freigabe als berechtigt hinterlegt ist):
Server 2012R1 … funktioniert
Windows 8.1 ….. funktioniert nicht
Windows 10 …… funktioniert nicht

Mit etwas Glück stößt man nach einigem Suchen auf die Information, dass der Zugriff mit Anmeldeinformation der Form Maschine\Benutzer erfolgen muss, damit dieser nicht zurückgewiesen wird.

Es welchem Grund Microsoft das Verhalten für lokale und Microsoft Konten unterschiedlich designed hat, weiß – wenn überhaupt – wohl nur Microsoft.

Windows Update kann nicht nach Updates suchen, da der Dienst nicht ausgeführt wird

Problem:
Windows Update scheitert unter Ausgabe der Fehlermeldung Windows Update kann nicht nach Updates suchen, da der Dienst nicht ausgeführt wird. Ein schneller Blick in die Dienstekonsole straft diese Fehlermeldung jedoch Lügen, denn der Dienst läuft.

Mögliche Lösungen:
1. Microsoft Fixit versuchen. Wird wahrscheinlich (da der Dienst ja läuft) nicht viel bringen.
2. (auch nicht immer zu emfehlen) Selbst bei frisch installierter Maschine Befall mit schädlicher Software vermuten, alles platt machen, neu installieren, aktualisieren – um hernach wieder mit dem gleichen Problem konfrontiert zu werden. 😉
3. (zumindest bei Geräten von Lenovo) Prüfen, ob – auf welchem Weg auch immer – der Intel Matrix Storage Manager auf dem Gerät installiert ist. In diesem Fall im Gerätemanager dem HDD-Controller einen Besuch abstatten und zum vorher installierten Treiber zurückkehren. Windows Update wird daraufhin mit hoher Wahrscheinlichkeit wieder funktionieren.

PS: Im Lenovo-Forum existiert ein im Jahr 2009 gestarteter Thread, der sich des Themas annimmt. Um so erstaunlicher ist es, dass Lenovo z.B. mittels des hauseigenen Hilfsprogramms System-Update den problematischen Treiber bis heute zur Installation anbietet. 🙁

AutoVervollständigen funktioniert nicht in Outlook 2010 nach Umzug auf neuen PC

Nach der Migration eines Outlook-Postfachs (IMAP) auf einen neuen PC gab es mal wieder Probleme mit der von zahlreichen Benutzern sehr geschätzten Funktion “AutoVervollständigen”.

Erste Anlaufstelle:
http://support.microsoft.com/kb/2682333/de
und dort der Abschnitt “Wenn Sie ein privates E-Mail-Konto besitzen”.

Das löst das Problem für neue Adressen, allerdings sind die bisher gespeicherten Adressen dann verloren, deshalb waren im Nachgang zusätzliche Maßnahmen erforderlich.

a) Kopieren der Datei Stream_Autocomplete_***.dat aus dem Ordner old_RoamCache in den Ordner RoamCache.
b) Umbenennen der im Ordner RoamCache vorhandenen Datei Stream_Autocomplete_***.dat.
c) Abschließendes Umbenennen der aus old_RoamCache kopierten Stream_Autocomplete_***.dat, so dass Sie den alten Namen der im Schritt b umbenannten Datei trägt.

Eine andere Möglichkeit wäre sicherlich auch die Nutzung von Nirsofts nk2edit gewesen, allerdings hätte dies Lösung einen höheren Aufwand bedeutet. Ganz abgesehen davon, dass mir die Lizenbedigungen des Tools nicht so gut gefallen.

Ralph Lehmann – Computerservice und IT-Beratung Leipzig

Kundenfragen zu Acer Reliability Promise

und meine Antworten dazu:

Was ist das jetzt schon wieder?
Ein Garantieversprechen.

Was genau bedeutet es?
Wenn Ihnen im ersten Jahr ein Acer Gerät kaputt geht, bekommen Sie einen Teil des Geldes zurück, und das zusätzlich zur kostenlosen Reparatur.

Bei allen Geräten?
Nein, nur bei denen für Profis. Veriton, Travelmate, etc.

Sollte ich den Aufwand in Kauf nehmen und wirklich alle Geräte nach dem Kauf für das Programm anmelden?
Meiner Ansicht nach – nein. Denn ich habe es noch nie (Präzisierung 24.10.215: bisher lediglich bei zwei Geräten) erlebt, dass eines dieser Geräte in den ersten zwölf Monaten “einfach so” kaputt gegangen ist.

Egal – ich will mich im Zweifel nicht ärgern müssen. Wo gibt es Infos von Acer selbst?
Offizielle Infos zu Acer Reliability Promise

Ralph Lehmann – Computerervice und IT-Beratung Leipzig

Ende von StartSSL Free im kommerziellen Umfeld?

Vor zwei Tagen habe ich bei start.com ein kostenloses Class 1 X.509 SSL-Zertifikat „StartSSL Free“für ein kleines Unternehmen beantragt, Zweck sollte der Zugriff von mobilen Geräten auf den internen Exchange-Server sein.

Die Registrierung als Benutzer verlief problemlos, ebenso die Einreichung des CSR. Dann jedoch erreichte mich folgende Nachricht von StartCOM: “… The request for a server certificate for <Domain> has been declined. For more information please contact us. Thank you!

Das tat ich dann auch, hier der relevante Teil der Antwort: ”

Thank you for requesting a digital certificate with us. However Class 1 certificates are not meant to be used for commercial activities or financial transactions according to our policy. For this purpose please consider upgrading to Class 2 or higher verification level.

 Please see https://www.startssl.com/?app=32 about how to enroll.

 Thank you for your understanding.”

Nach erneuter Kontaktaufnahme und Hinweis darauf, dass in den Policies von StartCom eine Einschränkung auf private Verwendung nicht zu finden ist, kam nichts mehr. Weder eine Antwort noch ein Zertifikat.

Ralph Lehmann
Computerservice und IT-Beratung Leipzig

Es spukt im LAN

Szenario: Neuer Kunde ruft an, berichtet über einen sich nun schon über Wochen hinziehenden Notfall.

Es gibt immer wieder Probleme im Netzwerk. Seine Hauptanwendung, deren Daten auf einem “Server” (alter Windows XP Computer, den die Sekrätärin als Schreibmaschine benutzt) ist oft von dem einen oder anderen Client aus nicht erreichbar. Mitunter funktioniert der auf dem Server freigegebene Drucker nicht, die Aufträge kommen auf dem Server an und stauen sich in der Warteschlange. Internet ist jedoch von allen Clients und vom “Server” aus immer erreichbar.

Der Kunde hat vor seinem Anruf mehrfach versucht, das Problem selbst zu lösen (sein bisheriger IT-Dienstleister hat seit Monaten keine Zeit), indem er zuerst einen vermeintlich defekten Homeplug AV Adapter ausgetauscht hat und schließlich in seiner Verzweiflung vergeblich versucht hat, das vor Jahren abgeschaltete WLAN durch Meter dicke Wände in Betrieb zu nehmen.

Hintergrund: Die Bürogemeinschaft arbeitet mit vertraulichen Daten, diese müssen zeitnahe bearbeitet werden. Aus Gründen der Umweltverträüglichkeit werden alle Geräte (PCs, Drucker, FritzBox) täglich zum Feierabend ausgeschaltet. Nur die 3 direkt mit Wandsteckdosen verbundenen Homeplug Adapter bleiben in Betrieb.

Auftrag: Quick and Dirty Fehlerbehebung ohne tiefgehende Analyse. Alles andere später.

Ausführung: Deaktivierung des WLANs, Verbindungstest zum Server (erst über die IP-Adresse aus dem Subnetz 192.168.178/24, dann über den Namen. Ergebnis: Funktioniert.  Nachher Test der Anwendung, funktioniert ebenfalls (wenn auch langsam, offensichlich ist über die Netzwerkinfrastruktur nicht mehr zu wollen). Drucker und Scanner tun. Neustart der Clients, es geht immer noch alles.

Wiedersehen, bis nächste Woche.

Nachspiel: Kunde ruft am Morgen danach wieder an. Anwendung und Drucker funktionieren nicht. Nein, er hat nix verstellt. Internet ist jedoch wie immer erreichbar.

Eine Analyse zeigt, dass mindestens einer der PCs mit einer IPv4 Adresse vom Typ 192.168.1/24 unterwegs ist und der Versuch, sich via Browser mit dem Standardgateway zu verbinden, die Login-Seite einer Vodafone Easy-Box öffnet. Und das bei einer Fritz Box als DSL Router …

Hier spukts wirklich! 🙂

Wer weiß die Lösung? Schreiben Sie mir oder posten Sie einen Kommentar!

Die Auflösung für alle folgt in ein paar Tagen.

Ralph Lehmann :: Computerservice und IT-Beratung

Kostenlose Online-Akademie zu Microsoft Office 2010/2013 und Microsoft Windows 8.0/8.1

In Kooperation mit Ingram Micro und easy-training.de biete ich Ihnen die Möglichkeit, sich kostenfrei durch die Absolvierung hochwertiger Multimedia-Kurse im Bereich Microsoft Office und Microsoft Windows weiterzubilden. Noch bis mindestens Ende 2014 finden Sie in meiner Akademie Module zu Word, Excel, PowerPoint, Outlook, OneNote, Visio, Windows 8.0, Windows 8.1, den Office Competence Feed und eine Umsteigerhilfe für Benutzer von Office 2003.

Nutzen Sie bitte nach Möglichkeit eine neue E-Mail Adresse, einen neuen Benutzernamen und natürlich ein Kennwort, dass sie bisher noch nie verwendet haben.

Ralph Lehmann

 

 

Windows 7 Installations FAQ :: ein kleiner Rückblick auf 2012

Das Jahr 2012 neigt sich seinem Ende entgegen und überall gibt es Rückblicke. Diesmal auch hier! 😉

Nicht ohne Stolz darf ich verkünden, dass ich mit meiner winzigen FAQ-Seite zum USB-Problem bei der Installation von Windows 7 einer Reihe von Hilfe suchenden Benutzern einen wichtigen Rat geben konnte. Denn immerhin wurde diese Seite seit Juli 2012 mehr als 1500 mal “angesurft”.

Die Besucher kamen übrigens aus ganz Deutschland (NRW hält den ersten Platz), aber auch einer nennenswerten Zahl von Österreichern und Schweitzern konnte ich so hoffentlich helfen. Und das kostenlos und frei von Werbung.

Ralph Lehmann
Computerservice und IT-Beratung Leipzig

Update 23.11.2013: Seit heute prangt auf der Startseite oben rechts ausnahmsweise ein kleines Banner einer Hilfsorganisation. Obwohl dies streng genommen auch Werbung ist, fehlt doch ein kommerzielles Interesse. Ich bitte um Nachsicht, zumal das Banner nach Weihnachten entfernt werden wird.